How to connect private with public key?

Jan 10, 2013 at 12:10 PM

Hello, I have used your tool to generate CSR using "Chose key from certyficate in MY store" option. Now I have imported generated public key but how shall I connect private key to it? Thanks in advance for your support.

Jan 11, 2013 at 4:19 AM


I'm not sure I understand correctly your question but I guess you mean linking the certificate you receive from the CA to the private key. Is it correct?
Because I don't understand what "generated public key" means.

So, if you mean the generated certificate, you should use my tool ImportIDRIXCert as explained on the main project page. Here is its link :


Jan 15, 2013 at 8:16 PM

Yes, it is about importing certificate from CA. I have a cert A with a private key which has expired so I was trying to renew it. I used your tool to create CSR using A from store. Now I received B cert from CA, imported in using MS tools but now in store I got it without private key. When I used the tool you provided I receive warning "No key container found that corresponds to the given certificate". Would it be possible to add an option to manually point to A while importing B to take A's private key?

Jan 19, 2013 at 12:34 AM


I have modified the ImportIDRIXCert tool in order to correctly import the certificate into the MY store and link it with the key. This version is available at the following link :
Could you please confirm that it indeed corrects your issue?


Jan 19, 2013 at 10:06 PM

Unfortunately the same error message persists. Is manual selection of source/private key certificate possible? I am not sure what part of CSR my CA (startssl) is actually passing to the final certificate - I remember reading that they overwrite most of CSR fields, not sure which of them.

Jan 21, 2013 at 7:33 AM

I have added an option in the import tool in order to manually select the certificate from the MY store that contains the source private key. Normally you should be able to import the certificate successfully now.

That being said, the previous version of the tool should have worked if you picked up the correct cryptographic provider used by the original version. Unfortunately this information is hidden but you can retrieve it by using my StoreExplorer tool (

Jan 23, 2013 at 8:10 AM

Thank you very much: pointing to the source certificate worked as expected. Pointing to correct provider worked as well as you described - thank you very much for your help :)